Jump to content
djoole

[résolu] Problème d'autonomie sur Macbook Pro Retina (3h30)

Recommended Posts

Yep.... Ca me soule rien que d'y penser...

J'aimerais quand même trouver quelqu'un qui a un MBPR et qui fasse le même test.

S'il faut c'est normal?

Faudrait que je vois combien il tient en faisant du web, mais ça veut dire qu'il faut que je scotche sur le web pendant au moins 3h30 non stop :punk:

 

Après j'ai remarqué que VLC fait switcher sur la Geforce.... Peut-être les messieurs de Mac Génération ont-ils forcé l'utilisation de la HD4000?? Mais je pense que si c'était le cas ils l'auraient précisé...

 

Je pourrai sûrement t'aider je reçois le mien cette semaine!

Share this post


Link to post
Share on other sites

Cool!!!

 

Alors pour être précis voici les conditions du test que j'ai effectué :

- Mac chargé à 100%

- Wifi et Bluetooth allumés, mais aucun trafic, et à 2m de la borne wifi

- Vidéo MKV H264 1080p piste audio en AC3 5.1 640kbps, hébergé sur le SSD du mac

- Xmarks chargé en fond de tâche (mais à priori il ne consomme rien dixit le moniteur d'activité)

- Aucune autre application qui tourne, pas même Mail (que je n'utilise pas)

 

Et le test en lui-même :

Lecture en boucle de la vidéo en plein écran en ayant débranché l'alim secteur

Le logiciel utilisé pour la lecture est la dernière version de VLC, réglages par défaut.

 

Pour info, lorsque la vidéo tourne (avec Geforce automatiquement activée par VLC), l'activité CPU pour VLC est d'environ 50-60%

 

 

Pim (ou toute autre personne au courant), tu ne saurais-pas si il existe une petit module de celui du genre de gfxCardStatus mais cette fois-ci pour savoir si le CPU intel est en turbo boost ou pas?

Où c'est peut-être faisable en natif sous Lion de voir la fréquence réelle du CPU?

Share this post


Link to post
Share on other sites

Yep j'avais oublié de le couper... je l'avais allumé pour tester une souris bluetooth...

Mais c'est quand même pas ça qui me fait perdre une heure d'autonomie alors que je n'ai aucune périphérique bluetooth de connecté?!? :shok:

Share this post


Link to post
Share on other sites

Bonsoir,

 

Je travaille régulièrement avec mon MBP dans le train. Et pour augmenter de façon très appréciable l'autonomie de ma batterie, je coupe le Wifi, la dent bleue, je ne mets pas de DDE, de clé USB... Ce n'est pas le fait d'avoir un périphérique de connecté, qui consomme des ressources, mais bien le fait que la dent bleue soit activée (ou le Wifi)

Share this post


Link to post
Share on other sites

Oki. Je n'ai plus qu'à refaire mon test sans la dent bleu ;)

Je ferai ça demain soir. Je vous donne RDV dans 2 jours pour les résultats!

Share this post


Link to post
Share on other sites

Enfin moi quand je lis ça :

Notre test plus empirique a quant à lui été une véritable surprise. Il consiste à utiliser la machine comme on l'utiliserait pendant une journée normale chez MacG, ici avec iA Writer, Numbers, iCal, Mail, le client Twitter Osfoora, Safari, et Dropbox, l'écran à 80 % et le son à 50 %. Et lorsqu'on dit journée, on ne ment pas : le MacBook Pro Retina a tenu 8h 45. Un deuxième test un peu plus exigeant, avec une partie de 35 minutes de Starcraft II et pas mal de lecture vidéo, notamment en Flash, a donné tout juste 6h d'autonomie. Bref, on pourra sans peine oublier le chargeur MagSafe à la maison et travailler avec le MacBook Pro Retina toute la journée.

Je me dis que j'ai quand même un souci d'autonomie!

Share this post


Link to post
Share on other sites

Yep j'ai trouvé la même info plus tôt dans la journée :)

 

J'ai donc procédé à un raz de la PRAM, et j'ai relancé un test de vidéo HD.

Résultat : 4h45! 1h15 de gagné sur les précédents essais.

 

Gagné me direz-vous, c'était la PRAM.

Bah pas sûr, parce que j'avais également forcé l'utilisation de la HD4000 sur batterie via le logiciel gfxCardStatus. J'avais oublié de le remettre en auto avant de lancer le test, argh!

 

Du coup je ne sais pas si c'est le fait d'avoir nettoyé la PRAM ou d'utiliser la carte interne plutot que la Geforce qui m'a fait gagner 1h15

 

Parce que MacGé arrive au même résultat (4h40) avec la Geforce!

 

Bref, je suis bon pour refaire un essai...

Share this post


Link to post
Share on other sites

Yep j'ai trouvé la même info plus tôt dans la journée :)

 

J'ai donc procédé à un raz de la PRAM, et j'ai relancé un test de vidéo HD.

Résultat : 4h45! 1h15 de gagné sur les précédents essais.

 

Gagné me direz-vous, c'était la PRAM.

Bah pas sûr, parce que j'avais également forcé l'utilisation de la HD4000 sur batterie via le logiciel gfxCardStatus. J'avais oublié de le remettre en auto avant de lancer le test, argh!

 

Du coup je ne sais pas si c'est le fait d'avoir nettoyé la PRAM ou d'utiliser la carte interne plutot que la Geforce qui m'a fait gagner 1h15

 

Parce que MacGé arrive au même résultat (4h40) avec la Geforce!

 

Bref, je suis bon pour refaire un essai...

 

Bonjour,

 

Tu ne crois pas que ton truc devient une prise de tête.

Au départ, tu voulais avoir un temps similaire que celui mesuré par MacG, et maintenant que tu y arrives, tu désires refaire le test en enlevant l'automatisme :shok:

Justement, si l'auto sur les CG est là, c'est bien dans un but d'améliorer les performances globales de la machine, et notamment la batterie. 2 CG dans un MBP, ce n'est pas pour faire jolie !!!! :ph34r: :ph34r: :ph34r: :ph34r:

 

Je suivais le fil, parce que je pensais qu'il y avait un problème, la RAZ de la PRAM semble avoir résolu ce problème.... N'est-ce pas suffisant ?

Share this post


Link to post
Share on other sites

Au pire, va à l'applestore mais à mon humble avis le problème est réglé ...

Share this post


Link to post
Share on other sites
Guest pim

Ce n'est pas nécessaire de refaire le test en entier : il suffit de lancer la vidéo quelques secondes, pour voir quelle carte est alors utilisée en mode « automatique » : si il s'agit de la Intel HD 4000, le test reste valable. Certes, si c'est l'autre carte, il faut tout refaire.

 

Maintenant je recommande la fameux effacement du fichier plist, car cela ne coûte rien et ne fait rien perdre, à part le fond d'écran.

 

Et enfin, je pense que l'on va vraiment avoir besoin de reparler de ce problème d'autonomie encore un moment, ne serais-ce lors du passage à Mountain Lion ; d'après MacGé cela règle des problèmes de lenteur notamment dans Safari, il faudra donc regarder aussi l'incidence sur l'autonomie. Donc j'encourage fortement djoole à poursuivre les essais ! Ce n'est en rien prise de tête pour nous en tout cas, bien au contraire, c'est très intéressant d'avoir un tel retour.

 

:)

Share this post


Link to post
Share on other sites

Je comprend ce que dit Romein : on a l'impression que Djoole passe plus de temps à trifouiller des tests qu'à réellement profiter de sa machine !

Share this post


Link to post
Share on other sites

Attention, réponses! :)

 

 

Bonjour,

 

Tu ne crois pas que ton truc devient une prise de tête.

Au départ, tu voulais avoir un temps similaire que celui mesuré par MacG, et maintenant que tu y arrives, tu désires refaire le test en enlevant l'automatisme :shok:

Justement, si l'auto sur les CG est là, c'est bien dans un but d'améliorer les performances globales de la machine, et notamment la batterie. 2 CG dans un MBP, ce n'est pas pour faire jolie !!!! :ph34r: :ph34r: :ph34r: :ph34r:

 

Je suivais le fil, parce que je pensais qu'il y avait un problème, la RAZ de la PRAM semble avoir résolu ce problème.... N'est-ce pas suffisant ?

Tu n'as pas bien suivi. VLC active la Geforce en auto. Donc MacGé a eu 4h40 avec la Geforce.

De ce fait, je ne suis pas sûr d'avoir obtenu 4h45 grâce à la PRAM ou grâce à la HD4000! Donc test invalide.

 

Qui plus est, je rappelle que si j'ai commencé à me prendre la tête ainsi sur l'autonomie, c'est que sur une utilisation normale, j'avais du mal à atteindre la fin de soirée avec un début d'utilisation de la batterie en début de soirée!!

 

 

Ce n'est pas nécessaire de refaire le test en entier : il suffit de lancer la vidéo quelques secondes, pour voir quelle carte est alors utilisée en mode « automatique » : si il s'agit de la Intel HD 4000, le test reste valable. Certes, si c'est l'autre carte, il faut tout refaire.

 

Maintenant je recommande la fameux effacement du fichier plist, car cela ne coûte rien et ne fait rien perdre, à part le fond d'écran.

 

:)

Yep, en auto c'est la Geforce qui prend la main, donc je dois refaire le test pour valider le fait que c'était la PRAM :)

Que le test soit OK ou NOK avec Geforce+PRAM propre, je rincerai le plist et le referai une autre (chuis comme ça, je veux que ça marche au mieux ce que j'achète à prix fort ;) )

Mais le maître mot (que je n'ai pas suivi), c'est changer une seule variable entre 2 tests, sinon on ne peut en tirer de fiables conclusions.

 

 

@ djoole : quel est ton modèle ? 2,3 ou 2,6 GHz ? 8 ou 16 Go de RAM ? 256, 512 ou 768 Go de SSD ?

J'ai l'entrée de gamme sans options.

 

 

Je comprend ce que dit Romein : on a l'impression que Djoole passe plus de temps à trifouiller des tests qu'à réellement profiter de sa machine !

Mes investigations peuvent te paraitre futiles/idiotes, mais si je les fais, c'est parce que j'ai la sensation que mon mac a un problème, et si c'est vraiment le cas, au prix de la machine, je ne veux pas m'assoir dessus.

Share this post


Link to post
Share on other sites

Oui oui je comprend tout à fait ta démarche Djoole, et je ne faisais pas cette remarque par méchanceté ou insolence, bien au contraire. Moi aussi je me suis pas mal posé de questions avec mon premier Mac (névrosé sur les bords que je suis) pour des raisons parfois valides, des fois futiles. Donc je comprend tout à fait ton envie d'aller plus loin et de ne pas négliger le problème. Mais je comprend également le point de vue de Romein.

Share this post


Link to post
Share on other sites

As tu effacé l'assistant de migration pour le réinitialiser comme l'a suggéré Pim d'après l'article de MacG?

Share this post


Link to post
Share on other sites
Guest pim
J'ai l'entrée de gamme sans options.

 

Bon choix ! :) Je pense que je vais me prendre celui-là pour la rentrée... dès que je serais fixé sur ses éventuels problèmes d'autonomie ! :P

 

As tu effacé l'assistant de migration pour le réinitialiser comme l'a suggéré Pim d'après l'article de MacG?

 

Faut pas effacer l'Assistant migration, malheureux ! Ah je vous jure, les requins, ils ont des méthodes... de requins ! :P

 

Non, il faut juste effacer un ancien fichier .plist, qui a été copié depuis l'ancien Mac sur le nouveau, alors qu'il ne convient pas. Effacer un .plist, ce n'est rien du tout : le système va en créer en un nouveau immédiatement. Donc c'est sans douleur. :)

Share this post


Link to post
Share on other sites
J'ai l'entrée de gamme sans options.

 

Bon choix ! :) Je pense que je vais me prendre celui-là pour la rentrée... dès que je serais fixé sur ses éventuels problèmes d'autonomie ! :P

 

De même. Je trouve que c'est un très bon produit, même sans les options ! :cool: Mais je pense quand même attendre que la rumeur sur le 13" se précise... Si un tel MBPR 13" s'averait, je tomberais amoureux... :wub:

Share this post


Link to post
Share on other sites

@djoole : désolé, je suis un peu obtu !!!! Faire des tests pour comprendre comment ta machine fonctionne, je suis tout à fait d'accord. S'inquièter parce que les benchs sont loin des valeurs constructeurs, je te suis toujours. Mais quand tu dis (je résume) je refais le test parce que j'étais en auto, et la CG n'était pas celle escomptée, je suis surpris. Tu ne crois pas que dans la vraie vie, tu laisseras Lion gérer tout seul les CG, et ce qui t'importe c'est bien l'autonomie obtenue avec les choix fait par Lion (à bon escient ou pas -- c'est un autre débat).

 

Maintenant, ce qu'il faut savoir, c'est comment optimiser cette autonomie, non pas en jouant sur des choix de Lion, mais bien sur les divers périphériques que tu utilises, ou pas. Ainsi, pour reprendre mon cas personnel, le travail dans le train s'effectue SANS Wifi, sans Dent Bleue, ni DDE, ni lecteur optique. Je gagne facilement 1h d'autonomie. J'évite d'utiliser FCPX, sinon je sais que mes ressources énergétique fondent rapidement (utilisation de la carte Geforce). Je sais ainsi que j'ai environ 5h d'autonomie. J'ai fais le test, mais sans essayer de me rapprocher d'un bench quelconque. L'autonomie me suffisait :hihi: , et si je dois utiliser un périphérique comme un DDE, je sais que l'autonomie va chuter... à moi de surveiller, et à être prévoyant.

 

Enfin, et désolé d'être méchant, mais je ne pense pas que tes tests soient vraiment juste :hmmm: :

  • Tu as l'air de manquer de méthodes. Les choix des critères de tes divers tests sont un peu brouillons (tu les as, je pense, dans ta tête, mais rien d'écris), ce qui enclenchent des tests non-valables -- oublis de certains critères.
  • Les resultats ne sont pas écrits dans une fiche synthètique pour permettre une étude claire, nette et propre, et en déduire des informations correctes
  • Je ne sais pas si tu as tenu compte de tous les paramètres : les ventilateurs sont-ils toujours à 2000 t/mn ? est-ce que la dissipation thermique se fait toujours de la même façon ? la luminosité du clavier est-elle activée ?....

Je suis comme Pim, en attente de bench, mais encore faut-il que les résultats soient opposables.

Share this post


Link to post
Share on other sites

As tu effacé l'assistant de migration pour le réinitialiser comme l'a suggéré Pim d'après l'article de MacG?

Réponse ci-dessous ;) :

Maintenant je recommande la fameux effacement du fichier plist, car cela ne coûte rien et ne fait rien perdre, à part le fond d'écran.

Que le test soit OK ou NOK avec Geforce+PRAM propre, je rincerai le plist et le referai une autre fois (chuis comme ça, je veux que ça marche au mieux ce que j'achète à prix fort ;) )

Mais le maître mot (que je n'ai pas suivi), c'est changer une seule variable entre 2 tests, sinon on ne peut en tirer de fiables conclusions.

 

 

 

J'ai l'entrée de gamme sans options.

Bon choix ! :) Je pense que je vais me prendre celui-là pour la rentrée... dès que je serais fixé sur ses éventuels problèmes d'autonomie ! :P

Je trouve aussi :hihi:

La différence de prix entre l'entrée de gamme et le HDG n'est pas justifiée... en terme de stockage si on se débrouille bien (NAS + disques externes si nomade) ça doit suffire avec 256Go. Et le gain CPU c'est pinuts.

Par contre je me suis longtemps taté pour mettre 16Go sachant que ce n'est pas évolutif. Mais ne faisant pas de vidéo, je pense que ça aurait été du luxe, même à long terme.

Share this post


Link to post
Share on other sites

quand tu dis (je résume) je refais le test parce que j'étais en auto, et la CG n'était pas celle escomptée, je suis surpris.

J'ai jamais dit ça, relis bien mes posts ;)

Je veux refaire le test car j'avais forcé l'utilisation de la HD4000, alors que par défaut VLC utilise la Geforce, du coup je n'étais pas en phase avec les conditions de tests de MacGé, ce qui faisait que mes 4h45 n'étaient pas comparables à leur 4h40 (en gros lorsque je vais refaire le test avec la Geforce -en auto-, la logique veut que j'ai moins que 4h45, et donc encore une différence avec la machine de MacGé)

 

Tu ne crois pas que dans la vraie vie, tu laisseras Lion gérer tout seul les CG, et ce qui t'importe c'est bien l'autonomie obtenue avec les choix fait par Lion (à bon escient ou pas -- c'est un autre débat).

Bah non, justement, je ne vais pas le laisser faire. Grâce à gfxCardStatus je vais le forcer à utiliser la HD4000 lorsque je suis en nomade (batterie).

 

Mais la question de ce topic n'est pas là, et je crois que c'est ce que tu as raté, la question n'est pas d'optimiser l'autonomie de ma bestiole, mais de savoir si ma bestiole a un défaut d'autonomie ou pas :)

 

Enfin, et désolé d'être méchant, mais je ne pense pas que tes tests soient vraiment juste :hmmm: :

  • Tu as l'air de manquer de méthodes. Les choix des critères de tes divers tests sont un peu brouillons (tu les as, je pense, dans ta tête, mais rien d'écris), ce qui enclenchent des tests non-valables -- oublis de certains critères.
  • Les resultats ne sont pas écrits dans une fiche synthètique pour permettre une étude claire, nette et propre, et en déduire des informations correctes
  • Je ne sais pas si tu as tenu compte de tous les paramètres : les ventilateurs sont-ils toujours à 2000 t/mn ? est-ce que la dissipation thermique se fait toujours de la même façon ? la luminosité du clavier est-elle activée ?....

Je suis comme Pim, en attente de bench, mais encore faut-il que les résultats soient opposables.

Comme tu dis, je vais pas m'amuser à vous sortir un plan de test, mais ne t'inquiètes pas ça fait 10 ans que je suis dans la valid, je m'en sors à peu près (tu remarqueras que j'ai quand même détaillé plus mes conditions initiales que les rédacteurs du test de MacGé ;) )

 

Bref, les faits sont que les MBPR peuvent avoir des défauts d'autonomie, causés entre autres par une PRAM pourrie, ou un fichier plist corrompus. Et pour le moment rien ne me permet de dire si je suis concerné.

Le seul fait pour le moment est qu'à conditions équivalentes, voire plus favorables (pas de polling Mail), mon MBPR tient une heure de moins que celui de macGé!!

 

La suite au prochain épisode!

Share this post


Link to post
Share on other sites

Allez comme tu es gentil je t'en débarrasse volontiers et pour rien du tout en plus :hihi:

Share this post


Link to post
Share on other sites

Comme prévu, je vous tiens au courant de mes investigations.

J'ai donc refait le test avec cette fois-ci le choix de la carte graphique en auto, et donc avec la Geforce, et j'obtiens 4h20; soit 20 minutes de moins que MacGé, et là on peut effectivement penser que ce delta peut provenir du MKV qui n'est pas le même, et peut-être du règlage luminosité/volume plus ou moins supérieur à celui de MacGé (80% je l'ai mis un peu au pif)

 

Bref, problème résolu, c'était la PRAM qu'il fallait réinitialiser, et hop, 1 heure de plus d'autonomie sur un test intensif (lecture en boucle d'une vidéo HD)

Je pense avoir gagné un paquet sur une utilisation normale.

 

Allez, maintenant une petite victoire, petit pied de nez à ceux qui ont accablé direct Flash sans chercher à regarder plus loin et en m'en mettant plein la tête de pas prendre pour argent content leur verdict ;)

Je l'savais qu'il avait un souci mon mac, non mais :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×