Jump to content

Configuration NAS Synology


Recommended Posts

  • Replies 429
  • Created
  • Last Reply

Top Posters In This Topic

Le 25/11/2019 à 17:52, pehache a dit :

Bah, tu copies un gros fichier (quelques centaines de Mo) entre un Mac et le NAS et tu mesures le temps qu'il met. Tu peux aussi regarder le moniteur d'activité, onglet "disques", pendant le transfert.

J'y penserai la prochaine fois. Mais j'ai le sentiment que ça dépote pas autant que prévu ou surtout espéré car la sauvegarde TM n'avançait pas bien vite.

M'enfin, ce n'est pas très grave car une fois le NAS remplis de nos données, ces dernières restant majoritairement des fichiers Office ou PDF, ils ne nécessitent pas un débit démentiel.

Il y a 15 heures, Sethenès a dit :

C'est normal. Comme il y a de la parité, la vitesse maximale d'écriture n'est que doublée (puisque c'est un 4 baies) par rapport à un disque dur unique. Si on ajoute les interfaces réseaux, etc, un NAS en écriture n'est pas "si" rapide que cela.

En lecture, la vitesse est triplée toujours en raison des 4 baies et de la parité.

Vitesse triplée voilà qui est intéressant. Qu'en est-il des temps d'accès ?

Link to post
Share on other sites
il y a 28 minutes, Baradal a dit :

J'y penserai la prochaine fois. Mais j'ai le sentiment que ça dépote pas autant que prévu ou surtout espéré car la sauvegarde TM n'avançait pas bien vite.

Une sauvegarde TM c'est déjà relativement lent sur un disque local, mais c'est encore pire sur un disque réseau. Mais le problème c'est TM et ses performances très moyennes, pas le disque réseau.

il y a 52 minutes, Baradal a dit :

Vitesse triplée voilà qui est intéressant.

Un disque 3,5" atteint sans problème 120Mo/s de débit séquentiel, or c'est aussi le débit maximum possible en éthernet gigabit (1Gb/s = 125Mo/s). Un RAID bien fait avec 3+1 disque peut en théorie tripler le débit (360Mo/s), mais ça ne se verra qu'avec un réseau éthernet 10Gb/s (et il faut aussi que le CPU du NAS suive, les échanges réseau sont assez consommateur de CPU, surtout s'il y a du chiffrement qui intervient).

Pour les temps d'accès à mon avis ça ne change pas grand chose.

Link to post
Share on other sites

Dans mon cas, c'est un peu différent car j'ai des disques WD RED qui ne tournent qu'à 5400 rpm d'une part et d'autre part, j'ai deux connexions réseaux d'1GB avec une simili-agrégation de lien.

Ceci dit, dans mon post original, j'évoquais les interfaces réseaux et le reste.

Ce qu'il faut aussi comprendre, c'est qu'un NAS est fait (en principe) pour servir plusieurs requêtes clients en parallèle. Evidemment si c'est de l'écriture pure ou de la lecture pure, il y aura les limitations physiques dont Pehache a parlé. Mais si ce sont des recherches par exemple, là on va profiter du boost de performance du RAID. Evidemment, il y a une énorme différence entre un RAID à 4 disques et un RAID à 14 disques comme on avait au taf' (mais toujours avec "seulement" 2 lignes 1 Gbit).

Ce n'est pas pour rien que Syno propose du cache lecture ou du cache écriture sur certains modèles. C'est bien la preuve qu'on peut encore gratter un peu de perf'. Ceci dit, pour le moment c'est trop limité. Quand j'avais des Macs, j'avais d'ailleurs mis le cache lecture sur le share ... Time Machine ...

Link to post
Share on other sites

Oui OK avec 2 liens agrégés pour faire du 2Gb/s le gain de débit du RAID doit être réel.

Par contre à mon avis le cache SSD ne sert qu'à masquer les temps d'accès, je ne pense pas que ça apporte grand chose aux lectures/écritures séquentielles.

Link to post
Share on other sites
il y a une heure, pehache a dit :

Oui OK avec 2 liens agrégés pour faire du 2Gb/s le gain de débit du RAID doit être réel.

Par contre à mon avis le cache SSD ne sert qu'à masquer les temps d'accès, je ne pense pas que ça apporte grand chose aux lectures/écritures séquentielles.

Tu as raison. Comme d'hab, tout dépend si l'ensemble de l'info est dans le cache ou pas. Je pense notamment à TM. J'avais un taux de hit du cache à 80%+.

Le NAS, c'est plus un 4x4 (véhicule tout terrain / SUV) qu'une formule 1.

Link to post
Share on other sites
Le 27/11/2019 à 10:23, pehache a dit :

Une sauvegarde TM c'est déjà relativement lent sur un disque local, mais c'est encore pire sur un disque réseau. Mais le problème c'est TM et ses performances très moyennes, pas le disque réseau.

Bonjour,

Que proposes-tu à la place ou à côté ?

Pour le moment il fait le taf. C'est surtout la sauvegarde des versions de fichiers que je veux mettre en place sur le NAS et directement dans la foulée une sauvegarde du NAS lui-même. J'ai un DDext 2.5" de 4To qui attend pour ça.

Le 27/11/2019 à 10:23, pehache a dit :

Un disque 3,5" atteint sans problème 120Mo/s de débit séquentiel, or c'est aussi le débit maximum possible en éthernet gigabit (1Gb/s = 125Mo/s). Un RAID bien fait avec 3+1 disque peut en théorie tripler le débit (360Mo/s), mais ça ne se verra qu'avec un réseau éthernet 10Gb/s (et il faut aussi que le CPU du NAS suive, les échanges réseau sont assez consommateur de CPU, surtout s'il y a du chiffrement qui intervient).

Pour les temps d'accès à mon avis ça ne change pas grand chose.

Sur un gros transfert j'ai mesuré environ15Mo/s. Bon c'est une fois pour toutes mais quand même c'est pas très rapide.

 

 

Le 27/11/2019 à 14:22, Sethenès a dit :

Dans mon cas, c'est un peu différent car j'ai des disques WD RED qui ne tournent qu'à 5400 rpm d'une part et d'autre part, j'ai deux connexions réseaux d'1GB avec une simili-agrégation de lien.

J'ai aussi 4 WD RED. Toutefois je n'ai connecté qu'un seul cable réseau. Ne sachant pas comment faire avec deux et de toute façon je doute y trouver un quelconque bénéfice.

 

Le 27/11/2019 à 14:22, Sethenès a dit :

Ceci dit, dans mon post original, j'évoquais les interfaces réseaux et le reste.

Ce qu'il faut aussi comprendre, c'est qu'un NAS est fait (en principe) pour servir plusieurs requêtes clients en parallèle. Evidemment si c'est de l'écriture pure ou de la lecture pure, il y aura les limitations physiques dont Pehache a parlé. Mais si ce sont des recherches par exemple, là on va profiter du boost de performance du RAID. Evidemment, il y a une énorme différence entre un RAID à 4 disques et un RAID à 14 disques comme on avait au taf' (mais toujours avec "seulement" 2 lignes 1 Gbit).

Ce n'est pas pour rien que Syno propose du cache lecture ou du cache écriture sur certains modèles. C'est bien la preuve qu'on peut encore gratter un peu de perf'. Ceci dit, pour le moment c'est trop limité. Quand j'avais des Macs, j'avais d'ailleurs mis le cache lecture sur le share ... Time Machine ...

Et pour augmenter le cache tu fais comment ? En rajoutant des SSD ?

 

Le 27/11/2019 à 19:11, LolYangccool a dit :

Time Machine est effectivement très lent en réseau, mais c'est super pratique et je ne peux plus m'en passer... ;)

Ça tourne en tache de fond je m'en rends même pas compte et c'est très bien ainsi.

Link to post
Share on other sites
il y a 37 minutes, Baradal a dit :

Que proposes-tu à la place ou à côté ?

Rien de spécial, c'était juste pour dire que la lenteur avec TM c'est "normal", sans que le NAS soit forcément fautif.

il y a 38 minutes, Baradal a dit :

Sur un gros transfert j'ai mesuré environ15Mo/s. Bon c'est une fois pour toutes mais quand même c'est pas très rapide.

Ah oui là effectivement c'est très lent. Tu es sûr que le NAS ne faisait rien d'autre d'important pendant ce temps ? Et c'était bien un gros fichier, pas plein de petits fichiers ?

Vérifier que le réseau est bien en Gb/s, pas en 100Mb/s (on ne sait jamais)

Link to post
Share on other sites
Il y a 2 heures, Baradal a dit :

Et pour augmenter le cache tu fais comment ? En rajoutant des SSD ?

Oui, si le NAS dispose de slot NVME M.2 (comme le DS918+) mais j'ai été déçu. On sent qu'ils en sont encore aux balbutiements, c'est en partie pour ça que j'attendais la 7.0. Entretemps, j'ai recyclé le SSD dans une autre machine.

Link to post
Share on other sites
Citation

Vérifier que le réseau est bien en Gb/s, pas en 100Mb/s (on ne sait jamais)

En 100Mb il aurait pas pu dépasser 11 ou 12Mo/s grand maximum. 15Mo/s c'est déjà trop.

Après, juste avant le remplacement de mon DS212+ par le 1515+, le CPU était en permanence saturé, trop de choses qui tournaient dessus, ce qui avait pour conséquence de ralentir très fortement les débits.
Il faut vérifier que les ressources du NAS ne soient pas saturées, ça pourrait éventuellement être la cause.

Link to post
Share on other sites

C’est pour ça que je lui demandais si le NAS ne faisait rien d’autre pendant ce temps. Mon  tout petit 218j atteint 50Mo/s  en SMB, donc le sien devrait saturer le lien ethernet sans problème 

Edited by pehache
Link to post
Share on other sites

Tu as bien de la chance ! Je ne dépasse pas 75Mo/s en NFS et 50Mo/s en SMB ou AFP. Je ne pense quand même pas que le Mac soit le goulet... peut-être la box (qui n'est pas récente).

Link to post
Share on other sites
il y a 31 minutes, pehache a dit :

Tu as bien de la chance ! Je ne dépasse pas 75Mo/s en NFS et 50Mo/s en SMB ou AFP. Je ne pense quand même pas que le Mac soit le goulet... peut-être la box (qui n'est pas récente).

Bah ce NAS ne sert que pour des backups.
C'est le 1515+ qui fait tout le boulot autrement. ;)

Un exemple de copie depuis le 218j en AFP :

De%CC%81bit%20copie%20depuis%20DS218j.pn

Edited by LolYangccool
Link to post
Share on other sites
Il y a 19 heures, Sethenès a dit :

Je pensais un peu comme vous, jusqu'à ce que je lise le commentaire d'un spécialiste réseau qui disait que la seule chose que mesure la vitesse de copie d'un fichier, c'est ... la vitesse de copie d'un fichier.

C'est pas faux. Mais ça peut quand même permettre de circonscrire ou d'éliminer des causes de ralentissement.

 

Link to post
Share on other sites
Le 29/11/2019 à 18:30, pehache a dit :

Rien de spécial, c'était juste pour dire que la lenteur avec TM c'est "normal", sans que le NAS soit forcément fautif.

Entendu

Le 29/11/2019 à 18:30, pehache a dit :

Ah oui là effectivement c'est très lent. Tu es sûr que le NAS ne faisait rien d'autre d'important pendant ce temps ? Et c'était bien un gros fichier, pas plein de petits fichiers ?

Vérifier que le réseau est bien en Gb/s, pas en 100Mb/s (on ne sait jamais)

Non le NAS ne faisait rien. Si c'était 25 000 éléments pour 15Go.

Comment vérifier le réseau ?

Chaque PC/Mac est doté d'un port ethernet, le NAS aussi, la Livebox Pro aussi. Les cables réliants les prises murales aux appareils sont en Gibagit cat 6. Reste le réseau intramuros du local que nous louons mais impossible de le vérifier bien qu'il soit indique "5" sur certains cables que je vois. C'est peut-être là notre facteur limitant.

 

Le 30/11/2019 à 20:52, LolYangccool a dit :

En 100Mb il aurait pas pu dépasser 11 ou 12Mo/s grand maximum. 15Mo/s c'est déjà trop.

Dans un sens ça me rassure, dans un autre ça ne résout pas mon problème de lenteur. Heureusement que nous ne manipulons pas de gros fichiers.

Le 30/11/2019 à 20:52, LolYangccool a dit :

Après, juste avant le remplacement de mon DS212+ par le 1515+, le CPU était en permanence saturé, trop de choses qui tournaient dessus, ce qui avait pour conséquence de ralentir très fortement les débits.
Il faut vérifier que les ressources du NAS ne soient pas saturées, ça pourrait éventuellement être la cause.

La ram est constamment utilisés à environ 12% quant au CPU, c'est rare qu'il dépasse 5% ou un peu plus. Jamais vu à +10% même lors de grosses copies.

 

Merci à tous pour vos réponses ;)

Link to post
Share on other sites
Le 25/11/2019 à 17:52, pehache a dit :

Bah, tu copies un gros fichier (quelques centaines de Mo) entre un Mac et le NAS et tu mesures le temps qu'il met.

Faut tout lire ? !!!

Link to post
Share on other sites
Le 30/11/2019 à 22:14, pehache a dit :

Mon  tout petit 218j atteint 50Mo/s  en SMB, donc le sien devrait saturer le lien ethernet sans problème 

J'ai refait quelques essais et apparemment je sature la liaison ethernet entre le Mac et le NAS en lecture et écriture en NFS, et en lecture en SMB. Il n'y a qu'en écriture SMB que c'est un poil en dessous (genre 95Mo/s). Tant mieux, mais du coup je ne comprends pas comment j'avais relevé initialement des performances bien plus faibles... Je ne sais plus comment je les avais mesurées en fait (probablement pareil, copie d'un gros fichier de quelques Go, mais je ne suis pas sûr). Ou alors il y a quelque chose qui a changé entre temps (et là encore je suspecte ma box, j'ai remarqué parfois qu'un reboot lui redonnait du peps).

 

Edited by pehache
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...