Jump to content
Sign in to follow this  
LolYangccool

Problème de stabilité de mon VPN

Recommended Posts

Posted (edited)

Bonjour,

Vous le savez peut-être, je suis en plein relancement de Geek on Mic, ma web radio, avec ma commune en partenariat.
Dans le cadre de ce relancement, on a recruté du monde et je dois également diffuser de la maison pour tous et non pas de chez moi. J'y ai donc installé mon matériel pour le live, mais les serveurs restent par contre chez moi.
J'ai donc utilisé mon VPN pour faire la liaison entre la MpT et mon appart.
Via le VPN transitent le flux audio que je diffuse, mais aussi le retour antenne (sens inverse donc), la téléphonie (standard chez moi), et je me connecte au serveur automate de la radio via RDP pour la contrôler de la MpT.

J'ai donc fais des tests via le VPN et si avec mon MacBook Pro en RDP je ne rencontre aucun problème avec le VPN, la connexion est stable, ne décroche pas etc..., mon PC d'animation a tendance à perdre la connexion très régulièrement, genre toute les 5 minutes. Le PC qui sert au standard n'a pas l'air non plus de rencontrer de soucis particulier mais je n'ai pas fais plus de tests que ça dessus. La config VPN du PC animation est la même que pour le MBP et le PC standard.
Ce qui a pour effet de couper le retour antenne, la téléphonie, la diffusion, RDP etc... Je remarque aussi que l'IP attribuée par mon serveur VPN (sous la forme 10.8.0.X) change dans ces cas là.

Le serveur VPN est un serveur OpenVPN installé sur mon NAS.

Je ne comprends pas. La première émission a bientôt lieue (je ne peux pas encore trop communiquer sur la date, je dois être synchro avec la com' de la ville), mais ça approche et sans VPN stable je ne peux rien faire, c'est vraiment un point ultra sensible de la chaine de diffusion.

Si vous avez des idées, merci beaucoup... :)

Edited by LolYangccool

Share this post


Link to post
Share on other sites
Posted (edited)

Tu le sais, la réseautique n'est pas mon fort. Donc, tout ce que je peux faire c'est te suggérer des techniques de test assez basique.

Ce que je ferais, c'est de tester le même PC mais dans un lieu totalement différent et dans des conditions différentes (exemple si ça déconne en wifi chez X, essayez avec un câble lan chez Y). Et faire le test complémentaire. C'est à dire de tester chez X mais avec un autre PC / Mac, mais dans les mêmes conditions.

En fonction du ça, tu sauras si le problème est chez X, sur le wifi du PC, en lien avec le VPN, etc. Au moins tu pourras te concentrer sur ce qui est problématique.

J'ai encore une question. Pendant les 5 minutes où ça fonctionne, est-ce que ça fonctionne Je veux dire, as-tu uniquement un ping et tu ne parviens à rien de plus - ou - tu peux absolument tout faire.

Autre question. Est-ce que ça coupe toujours après le même laps de temps (à mesurer avec un chrono), en plein milieu alors que tu l'utilises, ou justement quand tu ne l'utilises pas.

Je précise, je ne saurai rien faire de ces infos. Mais elles seront utiles à d'autres si tu dois poser la question sur d'autres forums.

Edited by Sethenès

Share this post


Link to post
Share on other sites
Posted (edited)

Salut Sethenes,

Je ne peux pas le déménager. Il est installé à la maison pour tous et ne bougera plus avant plusieurs mois, si un jour je change de local. C’est un fixe et si je dois le déménager il faut que je déménage tous mon setups radio, déjà pour faire les tests et ensuite parce que si je redémarre le PC avec des éléments débranchés (une carte son, la console de mixage ou autres, par exemple) ça va me dérégler tout mon setup et c’est un bordel long et pénible à régler de nouveau (plusieurs heures).

Quand ça fonctionne, je peux tout faire, à partir du moment où le VPN fonctionne il y a du trafic qui arrive en permanence (le retour antenne), depuis le serveur sur mon PC d’animation.

Ca ne coupe pas toujours après le même temps exactement, c’est en général entre 5 minutes et moins de 10 minutes environ.

Edited by LolYangccool

Share this post


Link to post
Share on other sites

Mais je ne comprends pas alors pourquoi tu as besoin d'un VPN si le PC en question est fixe et installé chez toi. Pourquoi ne pas le connecter à ton réseau ?

Share this post


Link to post
Share on other sites
Posted (edited)

Il n'est pas installé chez moi, il est à la maison pour tous de ma ville !

Il y a 1 heure, LolYangccool a dit :

Je ne peux pas le déménager. Il est installé à la maison pour tous et ne bougera plus avant plusieurs mois

Edit : Je me rends compte que Sethenès n'habitant pas en France, il ne sait peut-être pas ce qu'est une maison pour tous ?
Une maison pour tous est un bâtiment communal qu'il y a dans certaines villes.
C'est un centre socio-culturel en fait.

Edited by LolYangccool

Share this post


Link to post
Share on other sites

J'avais lu trop vite et merci pour la précision.

Comment est-il connecté la-bas, via wi-fi ou par LAN ?

Peux-tu essayer avec un autre PC/Mac dans les mêmes conditions ?

Il faut absolument faire des tests d'orientation pour circonscrire le problème.

Share this post


Link to post
Share on other sites
Posted (edited)

Il est connecté avec un câble Ethernet via un switch basique que j’ai ramené. Comme mes deux autres ordinateurs, l’autre PC et mon MBP (via un adaptateur Type-C vers Ethernet pour le Mac).

Comme déjà dis, mon MacBook Pro ne rencontre aucun soucis avec le même fichier de configuration OpenVPN.

Edited by LolYangccool

Share this post


Link to post
Share on other sites
Le 26 mai 2019 à 12:03, Sethenès a dit :

Il faut absolument faire des tests d'orientation pour circonscrire le problème.

 

Share this post


Link to post
Share on other sites

Par exemple remplacer ce PC par un autre et tester.

Il faut savoir si c'est le HW du PC, Windows qui est mal installé, le soft qui est mal configuré, que sais-je encore quoi d'autre.

Si un autre PC fonctionne dans les mêmes conditions, alors tu peux comparer ce qui les diffère. Si aucun des deux PCs ne fonctionnent alors ça ne sert à rien de chercher sur le PC, et il faut (par exemple) tester ce 2ème PC ailleurs. Si ailleurs ça fonctionne, alors .... Si ailleurs ça ne fonctionne pas alors ...

Ca, ce sont des tests d'orientation.

Share this post


Link to post
Share on other sites
Posted (edited)

Ok. J’ai déjà testé le PC du standardiste rapidement et ça avait l’air de fonctionner. Je pousserai cependant les tests un peu plus loin en durée parce que ça ne me semble pas suffisant pour tirer des conclusions.

J’essaye d’y aller demain avant la Keynote. :)

En tous cas une chose est sûr mais je l’avais deja écris, mon MacBook Pro n’avait pas de soucis de stabilité.

J'espère que je ne devrais pas le réinstaller pour ça ce PC, sinon c’est la galère...

Edited by LolYangccool

Share this post


Link to post
Share on other sites

Bon, c’est bon ! Ça fonctionne à priori. J’ai laissé tourner pendant environ 30 minutes et il n’y a plus eu de coupure nette comme j’en avais avant. :)

Share this post


Link to post
Share on other sites
il y a 11 minutes, LolYangccool a dit :

Bon, c’est bon ! Ça fonctionne à priori. J’ai laissé tourner pendant environ 30 minutes et il n’y a plus eu de coupure nette comme j’en avais avant. :)

As-tu modifié quelque chose ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×