Jump to content
Sign in to follow this  
LolYangccool

Problème de résolution DNS

Recommended Posts

Bonjour,

J'ai sur mon réseau un serveur DNS et je rencontre un petit soucis avec celui-ci.
Sur ce serveur DNS j'ai créé des enregistrements pour chacun de mes domaines.
Le soucis est que mon serveur n'est pas interrogé en premier et du coup, si ce domaine existe chez un registrar quelconque (OVH dans mon cas), la requête sera traité par les serveurs DNS d'OVH.

Le résultat c'est que si je partage un fichier via un de mes domaine qui existe donc chez OVH, le débit de téléchargement en local sera très lent, puisque la requête passe par la Freebox.
Par contre, si j'utilise l'IP locale, je sature le gigabit.
Le but est d'obtenir du gigabit en local aussi en utilisant mon domaine.

Si je fais un traceroute de mon domaine en ayant configuré ce dernier sur mon serveur DNS local, mais qui existe aussi chez mon registrar, j'obtiens ceci :

Traceroute+geekonweb.fr.png?v=2cd371f384

Si je fais un traceroute sur un domaine existant que sur mon serveur local, j'obtiens ceci :

Traceroute+consomc.fr.png?v=bc0b22a97778

Je ne comprends pas pourquoi alors qu'ils sont configuré de la même manière.

Normalement geekonweb.fr devrait être résolu par mon serveur local quand je suis chez moi et ne devrait pas passer par la Freebox, il devrait indiqué une IP locale...

J'ai posté sur nas-forum mais le soucis n'est pas encore résolu, donc si quelqu'un a une idée...

Merci.

Edited by LolYangccool

Share this post


Link to post
Share on other sites
Il y a 9 heures, LolYangccool a dit :

Le résultat c'est que si je partage un fichier via un de mes domaine qui existe donc chez OVH, le débit de téléchargement en local sera très lent, puisque la requête passe par la Freebox.
Par contre, si j'utilise l'IP locale, je sature le gigabit.
Le but est d'obtenir du gigabit en local aussi en utilisant mon domaine.

Tu le sais, réseau et moi, ça fait (presque) 2.

Mais un point m'étonne quand même. La résolution du nom permet au host de connaitre l'IP de son partenaire. Une fois cette IP connue, tous les paquets vont directement être dirigé par les switchs/routeurs vers le bon subnet.

Donc je peux comprendre que le temps de résolution soit allongé (peut-être même substantiellement) mais une fois que la résolution est faite, le transfert des données devrait se faire avec le même débit.

Share this post


Link to post
Share on other sites
il y a 2 minutes, LolYangccool a dit :

Oui, je ne comprends pas non plus. Et n'ai toujours pas de solution.

Pour moi, il n'y a qu'une seule solution, c'est d'avoir ton propre DNS et de passer toutes les requêtes non résolues au DNS actuel.

Share this post


Link to post
Share on other sites

J'ai déjà mon serveur DNS. C'est bien ça le soucis, les requêtes ne sont pas toutes résolu par lui. En fait il faudrait qu'il interroge d'abord mon serveur DNS? et si et seulement s'il n'a pas de réponse positive pour la requête, il interroge le DNS publique de FDN (qui est le serveur DNS que j'utilise).

Share this post


Link to post
Share on other sites
il y a 13 minutes, LolYangccool a dit :

J'ai déjà mon serveur DNS. C'est bien ça le soucis, les requêtes ne sont pas toutes résolu par lui. En fait il faudrait qu'il interroge d'abord mon serveur DNS? et si et seulement s'il n'a pas de réponse positive pour la requête, il interroge le DNS publique de FDN (qui est le serveur DNS que j'utilise).

Ben euh ... c'est pas un peu le principe d'un serveur DNS ? Ce qu'il sait traiter, il le fait et il sert de relais pour le reste.

Share this post


Link to post
Share on other sites
il y a 19 minutes, Sethenès a dit :

Ben euh ... c'est pas un peu le principe d'un serveur DNS ? Ce qu'il sait traiter, il le fait et il sert de relais pour le reste.

Bah si, mais c'est justement l'objet de mon topic. Le miens ne fonctionne pas comme ça...

Share this post


Link to post
Share on other sites
Il y a 2 heures, LolYangccool a dit :

Bah si, mais c'est justement l'objet de mon topic. Le miens ne fonctionne pas comme ça...

OK, je comprends le problème (je n'avais pas trop essayé vu que je sais que je suis pas très doué en réseau).

Je ne vois que trois options :
1) tu "crois" interroger ton DNS en 1er mais ce n'est pas le cas (je reconnais que c'est peu vraisemblable)
2) le DNS est mal configuré. Au lieu de rester en local ton DNS local passe d'abord la main au DNS principal qui te répond avec l'adresse "publique" de  geekonweb.fr. Comme "consomc.fr" n'existe pas, le DNS principal ne trouve rien et alors c'est ton DNS local qui prend le relais.
3) Ce n'est pas possible (mais j'y crois moyen).
4) la réponse 4), autrement dit, poste sur un forum de spécialiste réseau plutôt qu'ici ou que sur NAS-Forum.

Edited by Sethenès

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×